No poll attached to this discussion.

In this Discussion

  • January 2014
    Post: 1

    Talking to the greeter on Atmid Survey Station doesn't seem to update or advance the Heading to Atmid quest for me.  If it's tied into completing the other four quests on Atmid you may want to add that to the objectives.
  • January 2014
    Post: 2

    I am also having this issue.
    I went ahead and did all of the other quests on the island, but I'm still stuck at this portion of the questline.
    Some help would be much appreciated.

    I also noticed that 3 of the 4 side-islands you go to through Atmid all had the DeSync errors on them when the "Would you like to leave now?" window popped up... just an FYI
  • January 2014
    Post: 3

    Same here did all of the missions and their still isn't quest greeter. I don't have any Desync while on those quests
  • January 2014
    Post: 4

    I am now looking into this as we speak (or type), thanks for the feedback guys!
  • January 2014
    Post: 5

    Can't wait to press on
  • January 2014
    Post: 6

    I would like another little detail from you guys regarding this...

    1. Before turning (or trying to) in the Heading To Atmid quest, did you complete all of Snake Grass Enclave?

    2. Did you have any errors/issues on Snake Grass Enclave?
  • January 2014
    Post: 7

    Hi! I have this issue too. I have done all of Snake Grass Enclave. I did have the desync issue on the rebel rats before that got fixed, but no problems after that.
  • January 2014
    Post: 8

    Interesting. Anyone else with this issue should post a response to my previous question as well.

    Thanks for the feedback, I have an idea as to why this may be happening. I'll look into it and get it sorted out. Every detail helps!
  • January 2014
    Post: 9

    1. Yes

    2. only the issue with desync from yesterday
  • January 2014
    Post: 10

    I have an interesting idea I would like one of you to try!

    Go back to your starting island and see if Archibolt still has the silver question mark floating above his head. If he does, talk to him about heading to Atmid, then go back to Atmid Survey Station and see if you can complete the quest.

  • January 2014
    Post: 11

    I can't try it anymore.  I tried giving up the quest to restart it, but Archibolt didn't give me the quest again.  I simply lost the quest.

    I can answer your question though.  Your suggestion was the first thing I tried when I found the error, and it didn't make a difference.
  • January 2014
    Post: 12

    I also finished all of the Snake Grass Enclave, I believe. : )

    I've gone back to Archibold 3 times to talk to him, but nothing changes. Each time I go back, I try something different. First, I tried going to Atmid directly from the questline, then I tried going through the navigation window.
    Neither way worked with the Greeters, because they didn't have quests to be completed over their heads! They merely gave directions ... I think that is probably the problem... They didn't have the ?'s to click on. They simply directed you towards the quests that were already there
  • January 2014
    Post: 13

    Thanks everyone, I have found the issue that causes this and fixed it.

    Will be in the next build! Woooo progress!
  • January 2014
    Post: 14

    I didn't finish all of snake gras quests dou to desync problem with the "the rat king rises" quest killing those rats makes the game desync
  • January 2014
    Post: 15

    That has been fixed already.  You should be able to kill them now, but make sure your client is updated.
  • January 2014
    Post: 16

    Talking to Archi again doesn't help. Also he says: "Head on over to Armid. I sent word you were coming." Maybe that's the problem, we are all going to Atmid when the real quest is at Armid :P
  • January 2014
    Post: 17

    I am going to mark this topic as [Resolved] for now, since I have found the issue and corrected it. Will be in the next build.

    If the quest turnin is still bugged afterwards, feel free to post about it again but it should be working correctly after our next update.